How to use the offline backup feature

The offline backup feature enables the automatic running of a backup if a previous backup schedule was missed. It’s a good feature to enable if your machine is not always connected to the internet to perform backups.

  1. Open the CyberSecure backup agent
  2. Go into the program settings by using the cog icon:
  3. For the STANDARD edition, check the “Enable offline backup” section and leave the default values.
  4. For the ADVANCED edition, go into the “Extra backup” settings and enable offline backup from there, leave default values:
  5. Save settings and exit
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ShadowProtect: BMR with additional partitions

  1. Select the image file of the next partition you want to restore
  2. Enter encryption password
  3. When choosing the destination, right click on the “Unallocated space” and select “Create extended partition…”
  4. Use the remaining space on the disk and click “OK”
  5. Right click the “Unallocated space” and select “Create exact logical partition at the beginning of free space”
  6. If this is the last partition you’re restoring select “Create logical partition using all unallocated space”
  7. Tick the newly created volume and click “Next”
  8. Tick “Finalize the volume at the end of this restore” and click “Finish”
  9. Use the following options and click “Next”
     

    1. Restore MBR: UNTICKED
    2. Restore Disk Hidden Tack: UNTICKED
  10. Click “Finish” to restore this volume. You can do this while the previous partition is being restore, this job will be queued and executed automatically when ready
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ShadowProtect: How to select backup images on network share

  1. Click “Browse” when prompted to select the backup image
  2. Type in the UNC path to the share where your images are stored and click “Open”
  3. When prompted type in the username and password to authenticate to the share
  4. Select the source image you want to restore from
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ShadowProtect: Setting up Partitions for BMR

  1. In the ShadowProtect Recovery environment go to the “Disk Map” tab
  2. Right click on the unallocated space and click “Create primary partition”
  3. Set the size of the partition to be greater than or equal to the size of the partition you are restoring
  4. Following the same Process to create the remaining partitions you will restore
     

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ShadowProtect: determine disk and volume information

From the source machine in Windows

  1. Click Start > Administrative Tools > Server Manager
  2. Go to Storage > Disk Management
    This will give you the minimum size required for each partition
  3. Right click on the disk and select “Properties”
  4. Go to the “Volumes” tab
    This will give you the overall disk size and tell you if it’s MBR or GPT

From the ShadowProtect recovery environment

  1. Open Shadow Protect
  2. Click “Explore Backup Image”
  3. Browse to and select a backup image you want
  4. Type in the encryption password
  5. Expand “Image File Properties”
    This value will give you the original size of the volume
  6. Scroll down and expand “Original Partition Information”
    The value of “Style” will tell you if the disk is GPT or MBR
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JVM royalty module is not enabled (Mac OSX)

Issue

Backups completing with the following error

 

Cause

This is a known issue with version 6.27.0.0.

Resolution

To resolve perform the following:

  1. Download – http://download.cybersecure.com.au/6.27.0.0/obc-mac-hotfix-task11803.zip
  2. Stop the scheduler service
    • sudo /Applications/CyberSecure\ Advanced/bin/StopScheduler.sh
  3. Extract the obc-mac-hotfix-task11803.zip into the directory
    • /Applications/CyberSecure\ Advanced
  4. Confirm that the files obc.jar, obcc.jar and obcs.jar have been replaced in the /bin folder (they should have the modified time of 2015-08-26)
  5. Start the scheduler service
    • sudo /Applications/CyberSecure\ Advanced/bin/Scheduler.sh
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How to Perform a ShadowProtect Bare Metal Restore

Prerequisites

  1. Location of the ShadowProtect backup chain, accessible by either local volume OR UNC network share, if the backups are stored on a network share, ensure you have the following:
    1. Network share path
    2. Network share domain\username
    3. Network share password
  2. The backup encryption password – this is extremely important since without the backup encryption password the data cannot be decrypted
  3. A destination machine to restore the backups – either physical or virtual
  4. Information about the backed up volumes. We strongly recommend matching the original physical disk, partition and volume structures exactly. There will be less things to go wrong if these all match what was running on the source machine.
    1. Physical disk size(s)
    2. Physical disk type(s): GPT / MBR
    3. Partition sizes
    4. Volume sizes (eg: C:\, D:\)
  5. ShadowProtect recovery ISO (supplied by CyberSecure)

Considerations

  1. Which backup snapshot to restore?
  2. If possible the destination physical disk and logical partition structure should match the backup source, this will make the restore process simpler and therefore less error-prone.
  3. Will the destination be a physical or virtual machine? Physical machines are more likely to have issues booting due to device drivers. Make sure you know your RAID/HBA controller chipset and have a copy of the controller device drivers ready for loading into the recovery environment.
  4. If destination is Hyper-V virtual machine, then:
    1. MBR disks to Gen 1 Hyper-V and;
    2. GPT to Gen 2 Hyper-V
  5. If the volume(s) you are restoring to are smaller than the original follow this guide, however we do not recommend trying to restore to smaller volumes as it adds complexity to the process.

Bare Metal Restore

  1. Boot off recovery environment media
  2. Start network support
  3. Set correct time zone
  4. If prompted Initialize the disk (choose MBR or GPT according to your configuration)
  5. Accept generated disk signature and click “OK”
  6. If you are restoring backup images from a network share (ie. NAS) now map the network drive in the ShadowProtect recovery environment
  7. If backups are stored on a network location you may need to manually set a static IP address
  8. Click “Restore Wizard” > “Next”
  9. Select a normal restore (the default)
  10. Browse to and select the image file you wish to restore from
  11. Enter your encryption password and click “OK”
  12. Information on the current image will be displayed. Proceed by clicking “Next”
  13. Change which point in time to restore from or click “Next” to continue
  14. First restore the boot volume. Right click “Unallocated space” and select “Create exact primary partition at the beginning of free space”
  15. Volume will be created. Tick the new volume and click “Next”
  16. Tick “Finalize the volume at the end of this restore” and click “Next”
  17. Select options as below

    1. Set partition active: TICK
    2. Restore MBR: TICK
      1. RESTORE MBR from the image file: SELECTED
      2. Restore disk signature: TICK
    3. Restore Disk Hidden Track: TICK
  18. Click “Finish” to begin restore
  19. Additional partitions can be restored if necessary, these can be added immediately and will be queued up automatically
  20. If necessary you can create partitions manually. Under the “Disk Map” tab create partitions to match the source (each partition must be greater than or equal to original partition in size)
  21. If you have restored to a virtual machine, we strongly advise taking a snapshot/checkpoint once the restoration is completed. This will allow a base from which to revert back to in case of boot issues into the operating system.
  22. Once the system has booted correctly, delete the checkpoint to avoid running out of free space on your hypervisors storage.

Booting the operating system

  1. If the operating system fails to boot then contact CyberSecure support.
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Removing a backup set from the offsite servers (Web Console)

  1. Login to the web console
  2. Click the “Backup Set” tab
  3. Select the backup set you wish to delete from the drop-down menu
  4. Click “Remove” and confirm by choosing “OK”
  5. Backup set is now deleted

Note: This will delete the backup set including all of its files from our servers. It may take some time for the deletion to complete and statistics to update.

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Cannot open Data fork

Issue

When performing a backup on Mac OS X, the following error message is received in the client log, and the backup job is terminated:

[YYYY/MM/DD hh:mm:ss][erro] Cannot open Data fork name Unknown Error (ErrorCode:-5000)

Cause

The message suggests that the operating system account that is running the backup process does not have sufficient permission to access a file(s) in the backup source.

Resolution

This issue will not affect the scheduled backup jobs and so will be replicated at the scheduled time, however if during the seeding process these files are required to be seeded then change the permissions on the files to be readable by the user account performing the seeding.

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Backing up shares from a Mac

Create a backup set for each share. Follow this for each backup set

  1. Click Go > Connect to Server…
  2. Type in the server address and share
    eg cifs://server/share
  3. Authenticate if needed, save credentials in keychain
  4. Mounted volume should appear
  5. Download the following script
  6. You will need to change the following variables to match your configuration:
    • BACKUP_SET_ID = “13XXXXXXXXXXXX”
    • USER_HOME=”/Users/myhome”
    • name = “/Volumes/share”
  7. Rename script to script.rb
  8. Make the script executable in terminal with the following command:
    chmod +x script.rb
  9. Open the backup software
  10. Create a new file backup set
  11. Tick the mounted volume
    eg /Volumes/share
  12. Go to “Command Line Tool” in backup set settings
  13. Add a Pre-Backup command with the following settings
    • Name: check mount
    • Working Directory: /[folder]/[path_to_script]
    • Command: ruby script.rb
  14. Save the backup job
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