Manual deployment of CA

Manual method (only do this if the auto method is not possible)

  1. Install the updated certificate
    1. Download this file. Assumes you will be downloading into your "Downloads" folder.
    2. File backup server edition: copy and paste the following into a terminal window:

      sudo /Applications/CyberSecure\ Advanced/jvm/bin/keytool -import -alias csfilebackup_ca -file $HOME/Downloads/cs_filebackup_ca.crt -keystore /Applications/CyberSecure\ Advanced/jvm/lib/security/cacerts -storepass changeit -noprompt

    3. File backup desktop edition: copy and paste the following into a terminal window:

      sudo /Applications/CyberSecure\ Standard/jvm/bin/keytool -import -alias csfilebackup_ca -file $HOME/Downloads/cs_filebackup_ca.crt -keystore /Applications/CyberSecure\ Standard/jvm/lib/security/cacerts -storepass changeit -noprompt

  2. If the key addition fails (perhaps with access denied), then reinstall the CS backup agent and try the process again.
  3. Restart the backup scheduler service
  4. Scheduled backups should run, however please contact our support if they continue to be missed
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Network problem: retry in…

Error

"Network problem, will retry in …" when attempting to run the backup from the agent GUI

Cause

This is due to restrictive filesystem permissions.

Resolution

Ensure the local user has permissions to both the local profile (.acb/.obm) and also the temporary spooling location

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Best Practice medical software backup

When using a third-party backup software that has an SQL agent, the user details required to access the database are set in Setup > Configuration > Database:

User: BPSBackup

Password: Set in the Database tab of the Configuration screen

Then perform a normal backup using our SQL server backup guide.

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Create firewall rule in Azure

  1. Log in to Azure portal
  2. Go to All Resources > Click your network security group > Inbound Security Rules
  3. Click Add
  4. Create a rule to allow port 5900
  5. In your Network Security Group go to Subnets
  6. Click Associate
     
  7. Choose the Virtual Network the VM is attached to and click OK
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Install CyberSecure Recovery Environment on server

  1. Download the CyberSecure Recovery ISO
  2. Mount the ISO on the machine being backed up
  3. Browse the mounted ISO to the following file: .\sources\boot.wim
  4. Copy this file to the location C:\Windows\System32\Recovery\

  5. Delete the existing file C:\Windows\System32\Recovery\ReAgent.xml
  6. Rename the copied file to WinRE.wim
  7. Run a command prompt as administrator
  8. Run the following commands
    1. attrib +H +S C:\Windows\System32\Recovery\WinRE.wim
    2. reagentc.exe /disable
    3. reagentc.exe /setreimage /path "C:\Windows\System32\Recovery" /index 1
    4. reagentc.exe /enable

  1. Check that it has installed correctly by running the following command

reagentc.exe /info

  1. Dismount the ISO file and delete if needed
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Restore Azure VM with StorageCraft SPX / ShadowProtect

  1. You should already have installed the CyberSecure Recovery Environment
  2. Start the VM in recovery mode by running the following in command prompt
    1. reagentc.exe /boottore
  3. Reboot the machine. The machine will start in the Recovery Environment on the next boot
  4. Ensure you have created a firewall rule to allow VNC access to your VM
  5. Using a VNC viewer connect to your public IP
  6. You should now be connected to the recovery environment
  7. Restore the machine as your would any other server
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Nextcloud client setup

  1. Install the nextcloud client on your system
  2. Open the nextcloud client
  3. Type in the address for the nextcloud server provided to you by CyberSecure
  4. Enter your account username and password
  5. Choose your sync policy and the local folder in which to sync into
  6. That should be it, the server will now sync to the chosen local folder
  7. Further configuration and additional settings can be set via the web console
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How to restore via windows previous versions (CyberSecure storage appliance)

There are two methods of performing a restore through windows previous versions:

  1. By file: this will display only the changed points in time for that file. Useful for if you need to revert back to or view changes to a specific file
  2. By folder: this will display all available versions and allow browsing down to the individual files/folder hierarchy. Useful for either restoring deleted/renamed files, entire folders or seeing the full view of what’s possible to restore
  3. For major restorations such as restore from a ransomware infection, we suggest contacting CyberSecure support as windows previous versions are not designed to restore large amounts of data

Restore by file

  1. Locate the file you wish to restore using windows explorer, right-click and choose “Restore previous versions”
  2. The list of available versions of this file are shown. In this example we have 2 prior versions available. This means there’s 3 possible versions. The current version and 2 prior changes
  3. You can preview the file by selecting a version and then using “Open”, here we are seeing the contents of each of the 2 past versions
    Initial version:


    Second revision

  4. You can revert to the previous version by selecting the desired version and clicking “Restore”

    OR by clicking and dragging the previous version into your desired folder
  5. If you drag the file back into the original folder (or a folder that includes a file with the same name), windows will prompt you to confirm the action for the identical filenames. To keep both copies (considering also that your latest version is also probably within CyberSecure’s snapshots), choose “Compare info for both files”
  6. Select both files and choose “Continue”
  7. You’ll now have the two copies of the files with the previous version copy renamed
  8. It’s advisable to delete the redundant copy as soon as possible to avoid any confusion.

Restore by folder

  1. Right-click on the folder you wish to browse previous versions within
  2. You’ll see a list of all available snapshots in the list of previous versions
  3. Choose a version and click “Open”, a windows explorer screen showing the exact contents of the snapshot will be displayed
  4. You can now use the normal copy/paste tools included within windows to restore your desired files & folders
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ShadowProtect recovery environment: setup static IP address

  1. Open the network configuration settings from the drop-down menu:
  2. Toggle the IP autoconfiguration button:
  3. Enter in the static IP address:
  4. Choose OK, wait some time and confirm the IP address has been statically asssigned in the bottom-left corner:
  5. We recommend using ping to confirm connectivity to various devices on the network.
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ShadowProtect: map network drive

  1. Go to Tools->Network Configuration
  2. Click into “Network drives” in the left sidebar

  3. Select the desired drive letter, enter the credentials. If this is a managed storage appliance CyberSecure will provide you with these credentials.
  4. Click “Connect”, the drive should be mapped successfully and the dialogue box can be closed by choosing OK.
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