How to set the temporary spooling location

  1. Open CyberSecure
  2. Go into the program settings
  3. Standard edition:
    1. Change the “Temporary directory for storing backup files” location as necessary. It is recommended to use a folder called “cybersecure-spool” for clarity and simplicity.
  4. Advanced edition:
    1. Select the desired backup set from the drop-down box:
    2. Click into the “Options” section:
    3. Change the “Temporary directory for storing backup files” location. It is recommended to use a folder called “cybersecure-spool” for clarity and simplicity.
    4. Change any other backup sets whilst you’re here.
    5. OK back to the main console
  5. Save your settings back to the off-site servers.
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Changing backup source selections

  1. Start the CyberSecure agent console
  2. Open the backup settings by clicking the cog icon
  3. Select the desired backup set by using the drop-down box:
  4. Click into “backup source”
  5. For extended file/folder selection, click “Advanced”
  6. Go through the backup source selections and select/deselect as necessary.
    IMPORTANT: we highly recommend only ticking folders and not individual files.
  7. Any nonexistent files/folders will be shown in RED – deselect these if they no longer exist.

  8. OK back to the main console
  9. Save settings when you are done making changes
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Email rule to filter backup reports

One strategy many resellers have is to use a central email address for client’s backup reports, eg: backups@yourcompany.domain

  1. Create two folders under a suitable “backups” folder, eg:
    1. Problem reports (missed, failed or backups with warnings)
    2. Successful reports

Then, setup your email server with the following two rules:

  1. This rule will move mail into the “Problem reports” folder:
    1. Sender is from @cybersecure.com.au
    2. Subject does not contain “Backup Report [Successful]”
    3. Don’t process other filters once this rule has been evaluated
  2. This rule will move mail into “Successful reports”:
    1. Sender is from @cybersecure.com.au
    1. Subject contains “Backup Report [Successful]”
    2. Don’t process other filters once this rule has been evaluated

This strategy will ensure that anything which is not successful to your backups email address will go into the “Problem reports” folder.

Posted in File backup: Server | Leave a comment

Error: NetUse Path:\\xxxx Error: An extended error has occurred.

Error

[BackupSetCmd.netUseShare] NetUse Login:VIC\CyberSecure Password:??? Path:\\Apsnas\apsdata Error: An extended error has occurred.

Cause

  • This error may be due to the system clock being out of sync with the network share clock

Resolution

  • Synchronise the clocks using NTP and retry the backup
Posted in File backup: Server: general issues | Leave a comment

Setting up a permanent auto-mounted share in OS X

  1. Open terminal
  2. sudo vifs
  3. Add a line in the following syntax:
    1. <hostname>:/<sharename> /Volumes/<sharename> url automounted,soft,url==cifs://<username>:<password>@<hostname>/<sharename>
  4. Dissection of parameters:
    1. <hostname = the hostname/IP of the NAS
    2. <sharename> = the share name being served from the NAS
    3. /Volumes/<sharename> – should match the sharename to avoid naming conflicts with Finder trying to auto-mount the same volume
    4. <username> = the CIFS username you’d like to use
    5. <password> = the CIFS password
    6. <hostname> and <sharename> should match the above variables
  5. To re-hash the mount points, run: sudo automount -vc

Further reading/troubleshooting

  1. See this guide for more information on auto mounting, including talking to a Windows AD domain
Posted in File backup: Server | Leave a comment

Error: Multiple connections to a server or shared resource by the same user….

Error

[BackupSetCmd.netUseShare] NetUse Login:VIC\CyberSecure Password:??? Path:\\NAS\nasdata Error: Multiple connections to a server or shared resource by the same user, using more than one user name, are not allowed. Disconnect all previous connections to the server or shared resource and try again.

This error may be followed by the following warnings:

  • Backup source “\\hostname\sharename\folder” does not exist !
  • Skip backing up “\\hostname\sharename” (network drive is not
    accessible)

Cause

There is another connection to the NAS within the same session that the backup is running under.

Resolution

  • Restart the online backup scheduler service – this should clear out any active network connections
Posted in File backup: Server: general issues | Leave a comment

error: java.lang.OutOfMemoryError: unable to create new native thread

Error

[BackupIpcThread.doRunException] error: java.lang.OutOfMemoryError: unable to create new native thread
Message: unable to create new native thread

Cause

  • The system has run low on memory

Resolution

  • Free up more memory by adding RAM or reducing the amount of applications running.
  • If running on a 32-bit operating system, consider upgrading to a 64-bit operating system to gain the advantage of larger memory address space.
Posted in File backup: Server: general issues | Leave a comment

How to check retention settings & cleanup old incrementals

To configure the image manager retention policies to recommended settings.

StorageCraft Image Manager v6

Check the retention settings

  1. Open Image Manager
  2. For each managed folder:
    1. Click the managed folder in the list
    2. Select “Retention Settings”
    3. Check that “Override global agent retention settings for this managed folder” is UNTICKED – we want to use global retention settings
  3. Confirm that all managed folders are using the global retention policy
  4. When back in the main console, click “Agent Settings” on the left side
  5. Select the “Global Retention” tab
  6. UNTICK “Move consolidated daily and weekly image files to a subdirectory instead of deleting”

Delete old incremental backups

  1. Browse to the path of the managed folder
  2. Delete any files within the “Incrementals” folder
  3. These are safe to delete as they are no longer used as part of the backup chain
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Configuring Windows Domain Authentication

  • Open CyberSecure Advanced

  • Open settings

  • Select the backup set in question

  • Update the “Windows Domain Authentication for Windows” section

  • OK back to the main console and “Save Settings”

Posted in File backup: Server: issues with backup | Leave a comment

Exceeded the [In-File Delta] -> [Maximum no. of Delta] setting

Error

Exceeded the [In-File Delta] -> [Maximum no. of Delta] setting. File “XXXX” is being backed up in its entirety because more than 100 delta files have been generated already.

Cause

  • This is a large file that has hit the configured delta chain limit, so the full file is being uploaded again and a new chain will be started.

Resolution

The following options are available:

  1. Let the backup complete by uploading the full files
  2. OR reseed the backup set in question
  3. OR reduce the backup schedule to run less frequently, therefore generating fewer deltas over time
  4. OR enable delta merge, however you can only have a rolling window retention and not an advanced retention policy with delta merge enabled.
Posted in File backup: Server: general issues | Leave a comment