[Error][New Mail] XXXX The system cannot find the file specified

Error:

[Error][New Mail] Mail=”SBS2003\Mailbox Store\User\Inbox\XXXX.msg” Error=”C:\CyberSecure-spool\1201549064328\1283040554906.msg (The system cannot find the file specified)”

Cause:

These errors messages occur while trying to backup individual mailboxes.

  1. If anti-virus software is installed and is active, it most likely will be automatically scanning the “Temporary directory for spooling” folder.
  2. When the CyberSecure Advanced agent runs, the agent makes a copy of the mail from the Exchange store into the temporary folder ready to be backed up offsite.
  3. Should this email contain a virus or other malware the anti-virus software does not allow the file to be written to the disk as a protective measure.
  4. CyberSecure Advanced expects the file to be there however and generates an error when the file is not present in the backup.

Resolution:

Add the CyberSecure “Temporary spooling location” to the “Exclusion” list of the anti-virus software so that the spooled emails are not scanned by the anti-virus engine.

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An incremental backup cannot be performed when circular logging is enabled

Error:

CExBackup::backupService:HrESEBackupSetup: Error Number 0xc800020e: An incremental backup cannot be performed when circular logging is enabled.

Cause:

Circular logging is enabled, which means that Exchange server writes out to only 4 transaction logs. Circular logging commits and recycles the logs to save disk space.

Circular logging is used for specific environments where an incremental/differential backup or transaction log backups are not required.

Resolution:

  1. Disable Circular logging on ALL Storage Groups
    1. Disable circular logging on Exchange 2003
    2. Disable circular logging on Exchange 2007
    3. Disable circular logging on Exchange 2010
  2. Restart the Microsoft Exchange Information Store from [Administrative Tools]->[Services].
  3. Run a Manual MS Exchange Database Backup through CyberSecure Advanced (with default options).
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Error Number 0xc8000232: Some log or patch files are missing

Error

CExBackup::backupStorageGroupLog:HrESEBackupGetLogAndPatchFiles: Error Number 0xc8000232: Some log or patch files are missing.

Cause

The message suggests that the corresponding information store has circular logging enabled previously.

Resolution

To resolve the issue, please check if the Information Store has been restarted after disabling the circular logging option. Furthermore, please perform a manual incremental MS Exchange Database Backup.

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There is not enough space on the disk

Error:

CExBackup::backupFile:WriteFile Path=\Temporary_Directory\Backup_ID\SERVER\Microsoft Information Store\Mailbox Store (SERVER)\File: Error Number 0x70: There is not enough space on the disk.

Cause:

The message suggests that the disk space on the MS Exchange machine has ran out. The disk where spooling directory is located doesn’t have enough space.

Resolution:

Free up some space on the disk.

In order to perform a MS Exchange server backup, it is required for the corresponding machine to have sufficient free space for the spooling of the server file. To resolve the issue, free up some disk space on the local drive so that the disk has enough space to hold the contents of the spooling directory.

Alternatively, you could also configure the temporary spooling of the server file to a network path, however ensure that the network path does not require user authentication.

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The last backup jobs of XX and XX don’t match for database XXXX

Error:

The last backup jobs of *.stm (none) and *.edb (YYYY-MM-DD-hh-mm-ss) don’t match for database ‘SERVER\Microsoft Information Store\First Storage Group\Mailbox Store’

Cause:

For MS Exchange server backup, *.stm and *.edb file are backed up in pair. If the error message above is received, it implies that during a previous backup, there was a problem with either the *.stm or *.edb file.

Resolution:

  1. Check back through the detailed reports to find the backup job where the EDB file was detected as being deleted.
  2. Go into the file explorer and UNDELETE the EDB from that job – this will restore the EDB file back into the “current” data area.
  3. Once the EDB has appeared back in the data area, to be safe, kick off a file validation to recreate the checksum files and validate the data.
  4. Ensure that the file validation is complete.
  5. Clear out the local temporary spooling folder.
  6. Finally perform an offsite MS Exchange server backup with default settings.
  7. The EDB should not need to be uploaded in it’s entirety, however a reseeding operation may be required if there are complications with restoring the EDB from the retention area.
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CExBackup::backupService:HrESEBackupSetup: Error Number 0x50d: (null)

Error:

CExBackup::backupService:HrESEBackupSetup: Error Number 0x50d: (null)

Cause:

The message suggests that the Exchange VSS writer has detected that an earlier Exchange snapshot backup operation is in an unfinished state. Therefore, the current backup operation and all subsequent backup operations are unsuccessful.

Resolution:

If an earlier Exchange snapshot backup operation is in progress, wait for the backup operation to finish before you start the next Exchange snapshot backup operation.

Also See http://support.microsoft.com/kb/910250

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The database missed a previous full backup before the incremental backup

Error:

CExBackup::backupService:HrESEBackupSetup: Error Number 0xc8000230: The database missed a previous full backup before the incremental backup.

Cause:

The message suggests that a full MS Exchange server backup has not been performed before the transaction log backup.

Resolution:

Perform 2x manual database backups (using default incremental delta settings) on the exchange backup set. The first backup may have warnings, whilst the second database backup should be successful.

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Either the target process, or the target thread’s containing process, is a protected process

Error:

CExBackup::backupService:HrESEBackupSetup: Error Number 0x50d:
Either the target process, or the target thread’s containing process, is a protected process.

Cause:

This is an error message that is returned by the OS & Exchange, it is not actually an issue with CyberSecure.
It means an attempt to prepare the storage group for backup failed because Exchange believes the storage group is already in the process of being backed up.

Resolution:

  1. Check under the system Event Viewer if there is any error related to the Exchange database.
  2. Verify if there is another backup job in progress while the current backup is preparing for backup.
  3. Verify if there is any other backup application that is performing backup on the same Storage Group.
  4. The message suggests that the Exchange VSS writer has detected that an earlier Exchange snapshot backup operation is in an unfinished state. Therefore, the current backup operation and all subsequent backup operations are unsuccessful. Check the output of the administrator command “vssadmin list writers”, specifically the “Microsoft Exchange Information Store” – it should be in a “Stable” state with “No error”.
  5. If an earlier Exchange snapshot backup operation is in progress, wait for the backup operation to finish before you start the next Exchange snapshot backup operation.
  6. If other backup software is not backing up Exchange at the same time as CyberSecure, many users have seen success simply by rebooting the machine.

Also see: http://support.microsoft.com/kb/910250

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Expect log sequence ‘XXXX’ but found ….

Error

Expect log sequence ‘6712’ but found ‘SERVER1\Microsoft Information Store\First Storage Group\E000671A.log’

Cause

This error can occur when the log sequence of MS Exchange was altered by other backup software. Thus, when CyberSecure Advanced software agent next performs an MS Exchange backup, the Exchange log sequence would not match the one that it is expecting.

With the broken sequence, the Exchange server cannot be restored to its latest state.

Resolution

  1. Perform a database backup manually via CyberSecure Advanced software agent (using the default settings). This will create a clean database backup and reset the log sequence.
  2. A second database backup may be required if the first backup shows the same error.
  3. If performing transaction log backups (VSS incremental) or differential backups through CyberSecure and there is other backup software running that is pruning exchange logs, then you will need to either:
    1. Set the other backup software to perform a COPY backup (so that it doesn’t prune transaction logs)
    2. Change the CyberSecure schedule to perform only database (VSS full) backups.

How to set copy backups for common 3rd party backup software

It’s vital that other backup software is set to perform “copy” backups so they don’t prune the Exchange transaction logs

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No *.edb found for database….

Error:

(MS Exchange Server)
No *.edb found for database ‘SERVER\Microsoft Information Store\First Storage Group\
Mailbox Store’
OR
No *.stm found for database ‘SERVER\Microsoft Information Store\First Storage Group\
Mailbox Store’

Cause:

The message suggests that during a previous backup, there was a problem with either the *.stm or *.edb file. Thus, the *.edb or *.stm file is not found on the CyberSecure Offsite Backup Server.

Resolution:

See this article on how to resolve this issue.

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