Error: “Cannot get remote file list”

Error

Cannot get remote file list” is displayed in the logs and the backup fails

Cause

This is normally caused by incorrect permissions on the local temporary folder

Resolution

Grant full filesystem privileges on the temporary local folder to “Everyone”.

In addition to this, our recommendation is to use a top-level folder such as “C:\cybersecure-temp” with no spaces in the folder name.

Posted in File backup: Desktop: general issues, File backup: Server: general issues | Leave a comment

How to enable/disable the backup schedule

  1. Open CyberSecure Standard edition by right-clicking the system-tray icon, or by using the start menu
  2. When in the main console of CyberSecure standard edition, click the scheduler icon and TICK or UNTICK “Run scheduled backup on this computer to activate or deactivate the schedule.
  3. Choose “OK”
  4. When back in the main console, click “Save Settings” which will save the settings back to our servers
  5. All done – you may Quit the software

 

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Applying a hotfix

Installing the latest hotfix patches on Windows

  1. Ensure the latest version of CyberSecure Standard/Advanced is installed (available from our support downloads page)
  2. Download the hotfix package from the above downloads page
  3. Open “Control Panel”-> “Administrative Tools” -> “Services” and stop the “Continuous Data Protection” and “Online Backup Scheduler” services
  4. Close the system-tray icon by right-clicking the CyberSecure icon and choosing “Exit”
  5. In Windows explorer, open C:\Program Files\CyberSecure Standard or C:\Program Files\CyberSecure Advanced
  6. Replace the “bin” folder with the version from the hotfix ZIP file, overwriting any files that already exist.
  7. You should now be running the latest hotfix version – open CyberSecure, click on the “About” button and confirm that the version number is higher than the latest version from the downloads page.
Posted in File backup: Desktop, File backup: Desktop: issues with backup, File backup: Server, File backup: Server: issues with backup | Leave a comment

Path XXXX does not exist! (SQL Backup)

Error

[Seed Load] Path “E:\XXXX\SBS\(local)\Database” does not exist!

Cause

  • The backup process does not have appropriate permission to the spooling location.
    OR
  • The SQL server user does not have permission to backup that database
    OR
  • The SQL database is offline

Resolution

  • Grant the user “everyone” FULL CONTROL to the spooling location as defined in the “Options” of the backup set
  • Ensure that the SQL privileges for the authenticating SQL user are set so that the SQL user can access the database
  • Bring the SQL database online
Posted in File backup: Server: general issues | Leave a comment

Another backup job is still running. Backup skipped

Error

“Another backup job is still running. Backup skipped” is displayed in the error report and the backup does not run.

Cause

  1. There is actually another backup running
  2. A backup has gone stale and is blocking any further backups

Resolution

  1. Check that a backup is not already running by examining the backup logs
  2. Stop any running backups by following the how to stop a running backup support article.
  3. Clear the backup queue to delete any stale backups.
Posted in File backup: Desktop: general issues, File backup: Server: general issues | Leave a comment

[logonSession] “XXXX” might have insufficient permissions to the mailbox ERROR=MAPI_E_LOGON_FAILED, Detail=ClassFactory cannot supply requested class

Error

[logonSession] “XXXX” might have insufficient permissions to the mailbox ERROR=MAPI_E_LOGON_FAILED, Detail=ClassFactory cannot supply requested class

Cause

The domain account used to take the backup:

  1. Does not have an exchange mailbox
    OR
  2. Does not have the required permissions on the exchange mailboxes.

Resolution

  1. Make sure the account has an active exchange mailbox
  2. Close down CyberSecure Advanced
  3. Ensure that the domain account is a member of the following groups:
    1. Domain Administrators
    2. Exchange Servers
    3. Exchange Windows Permissions
    4. Exchange All Hosted Organisations
  4. Grant full privileges to the exchange mailboxes using the following exchange management shell command (substitute $DomainAccount for the actual domain account user name):
    1. Get-Mailbox | Add-MailboxPermission -User “$DomainAccount” -AccessRights FullAccess
  5. Restart the “Microsoft Information Store” Service
  6. Log off and log back on again
  7. Run RunOBC32.bat
  8. Try to create the mail-level set
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Recommended power settings

Your computer’s power settings are very important to ensuring that unattended backups function correctly. Aggressive power settings can put the computer to sleep, which can result in missed backups and failure messages.

In short: our recommendation is that the power settings don’t ever put the computer to sleep.

Windows

  1. Under Control Panel > Power Options
  2. Click “Show additional plans”
  3. Select “High Performance”
  4. Close the Control Panel window

MAC OSX

  1. Under System Preferences > Energy Saver
  2. Tick “Prevent computer from sleeping automatically when display is off”
    mac_power
  3. Close System Preferences
Posted in File backup: Desktop, File backup: Server | Tagged , , , | Leave a comment

A nonrecoverable I/O error occurred on file “XXXX” 112(failed to retrieve text for this error. Reason: 15105

Error

[Microsoft][ODBC SQL Server Driver][SQL Server]A nonrecoverable I/O error occurred on file “C:\cybersecure-spool\1312939129295\SQL-SERVE\(local)\DB\DATABASE.bak.2012-01-04-21-00-00-000.ADD:” 112(failed to retrieve text for this error. Reason: 15105

Cause

  1. Generally this means there’s not enough space on the disk to spool the SQL backup. Here’s how to find/change the spooling location.
  2. It can also be from the volume on which the spooling location resides is heavily fragmented.

Resolution

  1. Free up some space
  2. Run a defragmentation tool and assess the fragmentation level on all volumes, defrag if fragmentation level is > 15%
Posted in File backup: Server: general issues | Leave a comment

Configuring backup sets in Linux/BSD (CLI mode)

Backup sets cannot be created in command line mode.

Before accessing the backup application in command line mode, please use the web interface to create the initial user account & backup set.

Add backup set(s)

  1. Login to the web console
  2. Create the desired backup set(s) via the web console

Set encryption password

  1. Run the configurator: sudo /usr/local/obm/bin/Configurator.sh
  2. It will prompt for an encryption password for each backup set – enter your desired encryption settings, please read our guide about passwords first
  3. Enable the relevant backup set(s) to be run on this computer
  4. Quit from the configurator
  5. Set spooling directory to /tmp in the web console
  6. Add desired schedule from web console for each backup set
  7. Seeding/backups can be taken via the “SeedLoad.sh” script

Important Notes

  1. The “Run scheduled backup on computers named:” field should match the output from the hostname command in linux.
  2. Check the $HOME/.obm/log/Scheduler/debug.log file for detailed information on the scheduler status. It should look similar to this:
    [2011/12/07 15:06:50][info] [BackupSet-0 (1323230680513)] Next backup will run in 0 hr 1 min 9 sec.
Posted in File backup: Server: issues with backup | Tagged , | Leave a comment

The requested operation cannot be performed on a file with a user-mapped section open

Error

C:\Documents and Settings\Administrator\.obm\config\Profile.sys
(The requested operation cannot be performed on a file with a
user-mapped section open)

Cause

Another process has locked the file at the time of backup.

Resolution

Ensure that there is no other software running that may be locking the file (both in reading and writing) at the time of the backup.

Posted in File backup: Server: general issues | Leave a comment