Errors backing Dropbox or OneDrive folders

Problem

You see the following errors on the backup report:

“Access to the cloud file is denied”

“The cloud operation is not supported on a read-only volume”

Cause

Attempting to backup a local folder that is synced with OneDrive or Dropbox. To save hard drive space, these programs have an option where the data is only downloaded locally when you open a file.

Files that haven’t been downloaded still appear on the file system as though they were local files, but they are not.

Solution

Make the top level folder and all files and folders under it available offline.

See this article for instructions on how to do this with OneDrive

See this article for instructions on how to do this with Dropbox

If you don’t need this folder in the backup

See this article on how to exclude folders from the backup

Posted in File backup: Desktop, File backup: Server | Leave a comment

Install Veeam MS365 Console

  1. Download the iso from our Downloads page
  2. Mount the .iso file
  3. Select Install > Veeam Backup for Microsoft 365 Console > I Accept > Install

  4. Unmount the .iso when finished
Posted in MS365 backup, Uncategorized | Tagged , , , , , | Leave a comment

Failed to resolve personal site owner

Issue

The following warnings appear in the backup:

Failed to resolve personal site owner. A user may not have a valid Microsoft Office 365 license with a SharePoint plan enabled.

Cause

A user account has been deleted, but their SharePoint personal site was not

Resolution

Delete the orphaned site as follows:

  1. Confirm the account has been deleted
  2. Open an administrative Powershell
  3. Download/Install SharePoint Online Management Shell: Install-Module -Name Microsoft.Online.SharePoint.PowerShell
  4. Connect to your Tenant and login as global admin: Connect-SPOService -Url “https://{companyname}-admin.sharepoint.com”
  5. Delete the ophaned site: Remove-SPOSite -Identity https://{companyname}-admin.sharepoint.com/{url}/{sitename}

“The requested operation is not supported for site”

If you see this warning in PowerShell, the site is being held by a retention policy and can’t be deleted. See this article on how to exclude from retention, then try the command again

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ShadowProtect unable to communicate with the Storagecraft activation server

  1. Verify that the machine can access https://activate.storagecraft.com/SPXLicensing.asmx without errors
  2. Stop the Storagecraft SPX service.
  3. Delete the license.lic and license.activate file in c:\programdata\storagecraft\spx
  4. Start the service and verify that the files are recreated.
  5. Try activating the licence again.
Posted in Other data protection | Leave a comment

POSIX: Failed to open file [/dev/veeamimageX].

Issue

Veeam backups via the linux agent are completing with the error:

No such device

POSIX: Failed to open file [/dev/veeamimageX]

Failed to open emulated disk

Failed to open disk for read

Failed to upload disk

Agent failed to process method {DataTransfer.SyncDisk}

 

Resolution

  1. Log into the Linux machine as an account with su or sudo access
  2. Unmount each Veeam virtual device that’s throwing errors by running:  umount /dev/veeamimageX
  3. Restart the Veeam service:  systemctl restart veeamservice
  4. Run the job again from the VBR console
Posted in Other data protection, Other data protection: errors | Tagged | Leave a comment

Increase veeam pre-freeze job timeout

Add a DWORD registry item called MaxGuestScriptTimeoutSec under HKEY_LOCAL_MACHINE\SOFTWARE\Veeam\Veeam Backup and Replication

The decimal value is in seconds

Posted in Other data protection | Leave a comment

Site URL has been changed

Issue

The following warnings appear in the backup:

Processing site https://xxxx.sharepoint.com/sites/sitename finished with warning: Site URL has been changed.

Cause

This is caused by changing the URL of a SharePoint site

Resolution

Delete the old URL for the site as follows:

  1. Open an administrative Powershell
  2. Download/Install SharePoint Online Management Shell: Install-Module -Name Microsoft.Online.SharePoint.PowerShell
  3. Connect to your Tenant and login as global admin: Connect-SPOService -Url “https://{companyname}-admin.sharepoint.com”
  4. Check if the site still exists: Get-SPOSite -Identity https://{companyname}.sharepoint.com/sites/{sitename}
  5. If the user still exists here, delete it: Remove-SPOSite -Identity https://{companyname}.sharepoint.com/sites/{sitename}
Posted in Uncategorized | Tagged , , , , | Leave a comment

Access to this web site has been blocked

Issue

The following warnings appear in the backup:

Failed to process site: https://xxxx-my.sharepoint.com/personal/xxxx_xxxx. Cannot contact site at the specified URL https://xxxx-my.sharepoint.com/personal/xxxx_xxxx. Access to this web site has been blocked. Please contact the administrator to resolve this problem.

Cause

This is caused by an orphaned sharepoint site from a deactivated user

Resolution

Delete the orphaned user and site as follows:

  1. Open an administrative Powershell
  2. Download/Install SharePoint Online Management Shell: Install-Module -Name Microsoft.Online.SharePoint.PowerShell
  3. Connect to your Tenant and login as global admin: Connect-SPOService -Url “https://xxxx-my.sharepoint.com”
  4. Check if the user still exists: Get-SPOUser -site “https://xxxx-my.sharepoint.com”
  5. If the user still exists here, delete it: Remove-SPOUser -Site “https://xxxx-my.sharepoint.com” -LoginName <email address of the user>
  6. Check if the personal site of the user still exists: Get-SPOSite “https://xxxx-my.sharepoint.com/personal/xxxx_xxxx”;
  7. Delete the orphaned site: Remove-SPOSite “https://xxxx-my.sharepoint.com/personal/xxxx_xxxx”;
Posted in MS365 backup | Leave a comment

How to perform a time machine restore

  1. Boot into Mac OS time machine recovery, either by:
    1. Holding the command + R keys when booting the system
    2. Boot from the Mac OS install ISO
  2. For a changed or new disk, first enter disk utility and erase the disk with a blank filesystem
  3. Ensure the SMB time machine share is read/write
  4. Perform the time machine restore
Posted in Uncategorized | Leave a comment

Veeam linux agent CLI restore

Mounting a restore point

  1. sudo veeam
  2. the veeam restore interface will open and will show the available restore points
  3. press “r”
  4. with the arrow keys select the job name and press enter
  5. select the restore point and press enter
  6. a message saying the backup is mounted successfully under /mnt/X should appear, press enter
  7. now go recover your files (preferably using rsync)

Dismounting a restore point

  1. sudo veeam
  2. press “u”

Troubleshooting

  • If you’re unable to dismount from the veeam CUI, umount /mnt/x from the shell and restart the veeam service: systemctl restart veeamservice and go back into the veeam CUI
Posted in Other data protection | Leave a comment