The parameter is incorrect

Error

[Error][New File] File=”XXXX” Error=”[com.ahsay.obc.core.bset.file.A]
[BackupRequestTask.uploadFiles] Unexpected exception for sFilename=\\XXXX sFileType=F, caused by [java.io.IOException] The parameter is incorrect. “

Cause

This is a result of underlying storage performance or reliability problems.

Resolution

  1. Check the Windows Event log for events from the “Disk” event source – ensure there are no underlying physical problems with the disk (bad blocks or RAID failures)
  2. Run a chkdsk on the filesystem
  3. Check the Event log for VSS related errors
    1. You may have no choice but to turn VSS off on that backup set
  4. If the issue still exists, contact CyberSecure support for further investigation
Posted in File backup: Desktop: general issues, File backup: Server: general issues | Leave a comment

“Unknown error encountered” when installing Image Manager

This error occurs because the “My Documents” folder points to a network location. This may have been done manually or be inherited through group policy that has Folder Redirection enabled

To check where My Documents points to click

  • Start > Username
  • Right click Documents and select Properties
  • Click the location tab

If this is set to a network location change it to the local machine

  • old location: \\server01\redirectedfolders\user\documents
    new location: c:\users\user\documents
  • Click OK and answer no to moving documents to the new location
  • Try to install Image Manager again
Posted in Uncategorized | Tagged , , , , , , , , , , , | Leave a comment

How to check event viewer for exchange errors

  1. Open the Windows Event viewer from Administrative Tools
  2. Right-click the “Application” log and choose “Filter current log”
  3. Select “Critical”, “Error”, “Warning” and choose the source as “ESE”.
    This will only show problem events related to the “Extensible Storage Engine”.
  4. Go through the listed events – carefully checking each one:
  5. Open and read the event detail – it will describe the issue.
    Be sure to check BOTH errors and warnings – as they could each contain useful information for diagnosis: 

    1. Example ERROR of Exchange failing to write to it’s database:
    2. Example WARNING related to the same issue:
  6. From here – it’s highly recommended to determine the cause of the underlying hardware issue – we discuss this in the next phase shown below.

 

Posted in Exchange Backup | Leave a comment

Pre-command script to stop backup

  1. Go to Client’s Backup Set in OBS console
  2. Under “Pre-backup command” heading fill out the fields
    1. Name: USB Not Present
    2. Command: IF NOT EXIST %DRIVE_LETTER%: ECHO USBDriveNotConnected >%userprofile%\.obm\ipc\BackupSet\%backup_set_ID%\stop(Where %DRIVE_LETTER% is the letter of the removal drive and %backup_set_ID% is the backup set ID number)

      eg.  IF NOT EXIST F: ECHO USBDriveNotConnected > %userprofile%\.obm\ipc\BackupSet\1425613161521\stop

    3. Working Directory: C:\
  3. Click Update
Posted in File backup: Server: issues with backup | Tagged , , , , , | Leave a comment

How to enable image manager bandwidth throttling

  1. Open Image Manager
  2. Go to “Agent settings”
  3. Go to the “Performance” tab
  4. Change the settings as appropriate, depending on the available upstream bandwidth of the internet link:

Posted in Other data protection | Leave a comment

Error: A dynamic link library DLL (MSExchangePS64.dll) initialization routine failed

Error

The error “A dynamic link library DLL (MSExchangePS64.dll) initialization routine failed” appears when attempting to setup an MS-Exchange 2013 backup

Cause

This is caused by the .NET 3.5 framework not being installed on the system.

Resolution

Install .NET 3.5 via the “Roles and Features” of Windows Server 2012.

Posted in Exchange Errors, File backup: Server: general issues | Leave a comment

How to move data within a backup set

Prerequisites for move detection

  1. The old filename must match the new filename
  2. The old file timestamp must match the new file timestamp
  3. The old file size must match the new file size

    Process for moving data within a backup set

    Take the following example:

    • Old data location: C:\myfiles
    • New data location: D:\test\myfiles
    1. Setup the CyberSecure standard/advanced edition on the new computer/new environment
    2. Ensure that the OLD LOCATION is a BLANK folder – C:\myfiles exists but is empty
      1. If the volume no longer exists, you can use the SUBST command to emulate a volume & path
    3. ADD the location of the new data to the backup source configuration. Do not remove the old location from the backup configuration
    4. Now you should have:
      1. The old backup locations (c:\myfiles) in the backup sources, which is blank
      2. The new backup locations in the backup sources (D:\test\myfiles), which contain the moved data
    5. Run the (or wait for the scheduled) backup and the system should detect that the data has moved from the old to the new locations
    Posted in File backup: Desktop: issues with backup, File backup: Server: issues with backup | Tagged , , , | Leave a comment

    How to find the filesystem location of an MS-SQL database

    1. Open SQL management studio
    2. Login with a valid username and password
    3. Expand “Databases”
    4. Right-click on the database in question and choose “Properties”
    5. In the left navigation pane, choose “Files”
    6. On the right details pane, scroll horizontally until you see “Path” -> this is the location of the SQL database and log files
    7. Highlighting the path and pressing ctrl-c will copy the path to the clipboard
    Posted in Microsoft SQL Server | Leave a comment

    Configuring retention policies

    Retention policies allow the storage and retrieval of previous versions of backup data.

    This is an important feature as it allows an easy method of complying with business data retention laws or guidelines.

    A convenient feature of retention policies is the ability to “go back in time” in the event if corruption has damaged files or if data has been deleted.

    By default, the standard retention policy is to keep the last 7 days changes.

    To configure retention policy settings:

    1. Open CyberSecure Standard and click the “Cog” icon to get into the backup settings:
    2. Check/edit the value in “Keep deleted files for X days” in the “Recycle Bin” box – this is the maximum number of days to keep changed or deleted files
    3. Make your desired changes and click OK
    4. Save settings back to the CyberSecure servers
    5. If you have reduced the retention period, the system may take up to 24 hours to prune previous backups and release free space
    Posted in File backup: Desktop: issues with backup | Tagged , | Leave a comment

    Error: SQL Server does not exist or access denied. ConnectionOpen (Connect())

    Error

    [Microsoft][ODBC SQL Server Driver][DBMSLPCN]SQL Server does not exist or access denied.
    [Microsoft][ODBC SQL Server Driver][DBMSLPCN]ConnectionOpen (Connect()).

    Cause

    TBD

    Resolution

    TBD

    Posted in MS-SQL Errors | Leave a comment