Image manager using large amounts of RAM

Problem

Storagecraft Image Manager uses huge amounts of memory causing the system to become very slow or unresponsive due to lack of free RAM and/or paging to disk.

Cause

We have seen this issue occur with out of date drivers, especially network interface card (NIC) drivers. The problem may be due to inefficiencies of the driver’s paged pool memory usage in Windows.

Resolution

Update all drivers to their latest versions – especially the NIC drivers.

Further reading

http://blogs.technet.com/b/markrussinovich/archive/2009/03/26/3211216.aspx

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How to disable Netgear UTM filtering

UTM devices can mangle connections causing interruptions, here’s how to disable UTM filtering on FTP connections on a Netgear device.

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Medical Director Restore Guide

Pre-flight Checklist

  1. Account username
  2. Account password
  3. Backup encryption password (if different than account password)

Method

  1. Install medical director and all updates
  2. Stop the HCN SQL server instance
  3. Perform a restore of the HCN SQL server instance from backup
  4. Restore the entire ManageEzy folder from backup
  5. Start the SQL HCN instance
  6. Login to medical director and perform some checks over the restored data
Posted in File backup: Server: issues with restore | Leave a comment

Stop backup if location not accessible

To prevent the backup from running due to a missing source location, add the following pre-command:

IF NOT EXIST e:\ echo. > C:\Users\cybersecure\.obm\ipc\BackupSet\1394756980694\stop

To check multiple locations, run it in a for loop

Posted in File backup: Server: issues with backup | Leave a comment

The system cannot find the file/operation canceled by the user (enterprise edition)

Error

07-May-2014 11:12:55 sbset 108 platform error opening the file (-2 The system cannot find the file specified.)
07-May-2014 11:12:55 sbset 404 Cannot open file smb://\\192.168.1.7\shadowprotect\server\SERVER-C_VOLSERVER-C_VOL-b002.spf (-2 The system cannot find the file specified.)
07-May-2014 11:12:55 sbcrypt 500 Unexpected end of the image file
07-May-2014 11:12:55 sbfile 404 Cannot open file smb://\\192.168.1.7\shadowprotect\server\SERVER-C_VOL-b002-i480.spi (-1223 The operation was canceled by the user.)

Cause

A bug in the shadowprotect diffgen function creates a bogus registry setting and makes the backup fail.

Resolution

http://www.storagecraft.com/support/kb/article/300

Posted in Other data protection: errors | Leave a comment

Recovering a SQL database

  1. The recovery of a SQL database backed up by ShadowProtect is very straight forward. The basic procedure is as follows.
  2. Determine the point in time you wish to recover to and mount the required ShadowProtect image(s)
  3. Within SQL Server Management Studio take offline the database concerned
  4. Delete both the database data and log files from disk
  5. Copy both the database data and log files out of the mounted ShadowProtect image(s) to the previous location
  6. Within SQL Server Management Studio bring online the database concerned
  7. Unmount the ShadowProtect image(s)
  8. That is it. If in step 4 you wished to relocate the database data and log files to another disk on the host, a slightly different procedure is required. This is explained in detail in SQL Books Online at http://msdn.microsoft.com/en-us/library/ms345483(v=sql.105).aspx.
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MS-Exchange recommended schedule settings

  • Perform a FULL database backup with no more than daily granularity
  • ENABLE delta merge AND set “Upload Full File when Maximum No. of Delta greater than” = Unlimited
  • No incremental backups should be performed by CyberSecure File Backup
Posted in Exchange Backup | Leave a comment

Disable password expiration on SQL user login

  1. Open SQL management studio
  2. Login with an appropriate admin-level account (using either Windows or SQL authentication)
  3. Expand Security – Logins
  4. Right click the desired login and choose properties
  5. Untick enforce password expiration
  6. Choose OK
  7. You can attempt to login to SQL management studio with those login credentials to confirm the account is working correctly.
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Another snapshot of this volume is already created

Error

[XXXX] [info] Waiting for other Backup Job finish
[XXXX] [info] [Shadow Copy] Another snapshot of this volume is already created
[XXXX] [info] Waiting for other Backup Job finish
….
[XXXX] [info] Now Starting Normal Backup Job

Cause

Another VSS snapshot is already present on the volume(s) that are being attempted to be backed up. The volume is locked so the backup continues on without using VSS.

Resolution

  1. Clear the backup queue + kill backup processes.
  2. Restart the windows “Volume Shadow Copy” system service
  3. Run “vssadmin list shadows” – the output should say “No items found that satisfy the query”, meaning that there are no volume shadows present.
Posted in File backup: Desktop: general issues, File backup: Server: general issues | Leave a comment

Where are the program files located?

Windows

  • CyberSecure Advanced: C:\Program Files\CyberSecure Advanced
  • CyberSecure Standard: C:\Program Files\CyberSecure Standard

Mac OS

  • CyberSecure Advanced: /Applications/CyberSecure Advanced
  • CyberSecure Standard:/Applications/CyberSecure Standard
Posted in File backup: Desktop, File backup: Server | Leave a comment