Error during seeding (bptree, X has been closed or index corrupted)

Error

XXX… Failed to remove element from bptree

index.bdb has been closed already

@373823d1 Index corrupted

Cause

This error we have seen occur during the seeding process.

It can occur when either the spooling location or seeding location database gets into an inconsistent state.

Resolution

Try clearing out the spooling folder & the backup seeding location, then attempt the seeding again.

Posted in File backup: Server: general issues | Leave a comment

BOOTMGR is missing

Error

BOOTMGR is missing.
Please CTRL-ALT-DELETE to restart.

Cause

Windows cannot load because the bootmgr file is missing or corrupted.

Resolution

  1. Copy the bootmgr file from the original windows CD to the root folder of the windows partition (d:\ -> c:\)
  2. Set the file attributes (hidden + system) on the bootmgr file: attrib +s +h c:\bootmgr
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Error occurred during initialization of VM

Error

[info] [OBM.OutputStream] Error occurred during initialization of VM
[info] [OBM.OutputStream] Could not reserve enough space for object heap

Cause

Generally this means that the server is out of memory. Open the Windows resource monitor, go into the “Memory” section and examine “Commit Charge”. If the commit charge has a high percentage, either more RAM or a bigger paging file will be needed.

Resolution

  1. Increase the paging file size
  2. Install more RAM into the system
Posted in File backup: Server: general issues | Leave a comment

Error: Database of “(local)” not found

Error

Database of “(local)” not found is shown in the detailed backup report.

Cause

This is most commonly due to an authentication issue between the backup software and the SQL server.

Often caused by the “Windows Domain Authentication” user password being changed.

Resolution

  1. Update the backup software “Windows Domain Authentication” with the correct password.
  2. Check the online backup scheduler system service and also update the password under the “Log on” section, if it is using a different user to the “Local system” account.
Posted in File backup: Server: general issues, MS-SQL Errors | Leave a comment

How to change the backup schedule

  1. Open the backup software
  2. Go into the program settings
  3. Select the appropriate backup set
  4. Click into the backup schedule settings
  5. From here, you can click on the schedule item in the right-hand box and use either “Add” if there are no schedules, OR the “Properties” button to alter the schedule.
  6. Additional schedules can be added in using the “Add” button.
  7. The schedule can be modified to only run between certain times – this is only valid for file backups and is not recommended for other types of backup.
  8. Note: DO NOT alter the “Run scheduled backup on this computer”, unless you know the implications of this.
    Changing whether the backup schedule runs on the computer can cause problems if the backup is run on a different computer than the set was configured on.
  9. When ready, OK out of the settings.
  10. Save settings to the offsite servers
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Running a backup multiple times a day

To run a backup multiple times a day, we can add in multiple schedules.

  1. Open the software
  2. Click the cog icon to get into the settings
  3. Choose the backup set name from the drop down menu
  4. Click on Schedule on the left hand side of the settings window
  5. Click add at the bottom of the right hand pane
  6. Add in a schedule for the desired time
  7. It’s also possible to add a periodic schedule to backup multiple times per day – this may provide better protection in more critical production environments
  8. Click ok and save the settings
  9. Close the software console and your desired schedule should now be active.
  10. To troubleshoot scheduling problems or missed backups, see our fixing missed backups guide
Posted in File backup: Server: issues with backup | Leave a comment

Medical Director Backup Setup Guide

  1. Install CyberSecure Advanced edition
  2. Create 2x backup sets: one for SQL databases, the other for the ManageEzy folder
    1. SQL Databases:
      1. Create an MS-SQL backup set according to our SQL best practices
      2. Capture the at least the HCNSQL database, plus any others required
      3. REMOVE the transaction log backup schedule from the set
      4. Check that the temporary spool location is a fast location with enough capacity to store the entire SQL database
    2. ManageEzy folder
      1. Create a file backup set
      2. Capture the c:\manageezy folder
  3. Save the settings to the servers
  4. Perform seeding as per normal if required

 

Posted in File backup: Server: issues with backup | Leave a comment

How to check the event viewer for hardware issues

  1. Open event viewer
  2. Right-click the “System” log
  3. Choose “Filter current log”
  4. Select Critical, Errors & Warnings
  5. Leave the source as blank, which selects all sources
  6. In the event list, look for the sources that your hardware generates. These vary depending on your storage controller
    1. Example of an underlying storage issue within a VMWare virtual machine (using the “pvscsi” driver):
       

      We can see that a reset was sent to the device, most likely due to a timeout that was experienced whilst reading or writing to the device.

      It can also be seen that the time correlates with our exchange errors above, confirming the fact that this machine had issues with its storage at that particular time.

    2. Examples of physical server with bad blocks on the disk:

  7. You should be able to now replace the faulty storage component. Once it’s been confirmed working correctly, run an integrity check/verification within your applications as since NTFS does not provide any error-correction capabilities, often some application data has been corrupted.
  8. Please contact our technical support if you require specialist expertise.
Posted in File backup: Desktop: general issues, File backup: Server: general issues, Other data protection: errors | Leave a comment

Microsoft SQL Server Restore Guide

Pre-requisites

  1. Ensure that the CyberSecure SQL backups have been successful
  2. Install the latest version of CyberSecure Advanced from our support download page
  3. Make sure you know the encryption password for the SQL backup set you wish restore
  4. Ensure SQL Management Studio is installed

How to restore a Microsoft SQL Server database

  1. Perform a normal file restore of the MS-SQL backup set(s) to a temporary location – this will extract the SQL .BAK files ready to be loaded into SQL management studio.
  2. Open SQL Server Management Studio.
  3. Login to the database server using an appropriate administrator-level account
  4. In the object explorer, right click on “Databases” and choose “Restore database…”
  5. Choose the radio button to restore from a device, then click the “…” to pop open the “Select backup devices” dialog
  6. Click Add to select the location of the restored backup files from the previous steps
  7. Locate the .BAK backup file to restore from
  8. Confirm that your selections are OK
  9. Review your restore parameters before proceeding
  10. In particular, on the options page you may want to overwrite the existing database
  11. When satisfied, click OK to proceed with the restore back into SQL server
  12. The restore should complete successfully
Posted in Microsoft SQL Server | Leave a comment

Using DISKPART to create partition

  1. cmd.exe
  2. diskpart
  3. list disk
  4. select disk x
  5. clean
  6. then use computer management/disk management to partition the drive

 

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