How to increase the shadow storage area

  1. Open Windows Explorer, right-click a local drive, from the context menu select Configure Shadow Copies.

  2. Set an appropriate limit large enough to allow shadow copies to be created. Typically 15-20% of the volume is needed to create shadow copies.

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No backup logs OR Exchange error “XXXX isn’t assigned to any management roles”

Error

During an exchange backup, the backup starts and immediately finishes with no backup logs being created.

OR the following error is seen:

[XXXX][error] [OBM.ErrorStream] com.ahsay.afc.microsoft.MSExchangeExpt: [listPublicFolderDatabases] Processing data from remote server failed with the following error message: The user “DOMAIN.local/Computers/VMEXCHANGE” isn’t assigned to any management roles. For more information, see the about_Remote_Troubleshooting Help topic.

Cause

The user defined in “Domain authentication for Windows” is not part of the “Organization Management” security group and so the backup cannot start

Resolution

  1. Edit the domain authentication for windows item in the agent config
  2. Enter credentials for a valid administrator user that is a member of the “Active Directory Users and Computers -> Microsoft Exchange Security Groups -> Organization Management” security group
  3. OR simply add an existing user to this security group and update the domain authentication details in the agent config.
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[ERROR] VSS_E_INSUFFICIENT_STORAGE

Error

[ERROR] VSS_E_INSUFFICIENT_STORAGE

Cause

There is not enough storage available to complete the snapshot.

Resolution

  1. Check the free space on all the volumes that have backup sources in the backup configuration. VSS requires a bare minimum of 320MB free space to function properly.
  2. Check & increase the amount of storage assigned to shadow copies via either
    1. The vssadmin CLI utility, OR
    2. Via the GUI
Posted in File backup: Desktop: general issues, File backup: Server: general issues | Leave a comment

LogonUserW Logon failure: the user has not been granted the requested logon type at this computer

Error

[XXX][error] [CM-SBS Exchange BackupSet (1417735865455)]
[XXX] Error uploading data. Reason = ‘[WindowsUtil:createProcessAsUserN] Failed to LogonUserW for wcDomain=’DOMAIN’ username=’cmadmin’. (1385) Logon failure: the user has not been granted the requested logon type at this computer.

Cause

The user defined in “domain authentication for windows” does not have appropriate access privileges (either local or group policy) needed to start the backup.

Resolution

  1. Check the credentials defined in the “windows domain authentication” settings
  2. Check local and group policies to ensure that the user has administrator privileges
  3. As a last resort – set the “Log On” settings for the backup scheduler system service to logon as a valid user, rather than the “Local System” account.

Further Reading

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Best practices for file backup agents

The advice provided here is for basic/entry level environments. For larger/more complex data sets, we recommend you contact us to discuss a tailored backup solution built from the ground-up to handle your storage and retention requirements.

Item Recommendation
OS volume The file backup agents are file data backup tools and are not designed to backup the operating system. Only capture data files. For operating system backup, contact CyberSecure for a solution designed to backup the entire OS.
Don’t backup the root of volume or drive letter, eg selecting the top-level C:\ or D:\ This will include hidden and system files that are stored in the root of a volume. Any files saved to this location in future will be added to the backup. Best to backup the specific folders you need
Structured databases SQL or Exchange databases are structured data and require their own backup set. Use a separate specific backup set type to capture these. Exclude them from the file backup set to avoid duplicating data.
Number of files in backup set For performance and reliability keep the number of files in each backup set ideally below 500,000 (and definitely below 1 million).

If the restore process is interrupted it cannot resume, so having a larger backup set means a slower restore time if the transfer needs to resume.

Restores cannot happen in parallel within the same backup set, so again it’s critical that each backup set is kept as small and agile as possible, with a restoration in mind.

Large files
  1. Put very large files into their own backup set (eg. PST files)
  2. Schedule sets with large files to run weekly
  3. Enable delta merging and set the “upload full file after number of previous deltas” to “Unlimited”
  4. Do not enable an advanced retention policy, this will turn off delta merging and cause major issues with quota sizes
Backup set organisation Design the backup sets with restoration in mind: split data logically up into priorities, eg: for smaller sets: “Data (current)”, “Data (archive)”
For larger sets, split by department, eg: “Accounts (current)”, “Accounts (archive)”.If data is really disorganized then local changes may be required first.

We cannot stress enough how important it is to keep the backup sets as small as possible and organised with restoration in mind.

Delta merging In general, leave delta merging switched off
Posted in File backup: Desktop: issues with backup, File backup: Server: issues with backup | Leave a comment

Universal unique identifier not found

Error

Universal unique identifier (UUID) was not found

 

 

 

Cause

Signature changed on disk

Resolution

  • Edit backup job
  • Re-select volume(s) to backup
Posted in ShadowProtect Backup | Tagged , , , , , | Leave a comment

E-mail Account Quota exceeded. Unable to add “XXXX”

Error

E-mail Account Quota exceeded! Unable to add “XXXX”

Cause

This error is caused by an insufficient number of mail-level licences for the CyberSecure backup service account.

If the entire Exchange store has been selected, then every mailbox in the store will be backed up, which could mean mailboxes created after the backup was initially setup.

Resolution

More Exchange mail-level licences are required to be purchased under the account: equal to or greater than the number of mailboxes attempting to be protected.

To backup only specific mailboxes, simply select the individual mailboxes in the backup configuration, rather than the entire store.

Posted in File backup: Server: general issues | Leave a comment

Generic log error messages are shown in capitals

Error

Log entries similar to the following are shown (these may also appear in the client user interface):

1     Info     xxxx     BS_ACB_START
2     Info     xxxx     BS_GENERAL_MSG
3     Info     xxxx     BS_GENERAL_MSG_WITH_SYMBOL
4     Info     xxxx     SC_SNAPSHOT_CREATED
5     Info     xxxx     SC_SNAPSHOT_DELETE

Cause

This can be caused by an auto-upgrade not completing properly.

Resolution

Please reinstall or upgrade the software from the original installer.

Posted in File backup: Desktop: general issues, File backup: Server: general issues | Leave a comment

Duplicate log entries and backup failures

Issue

When backups run duplicate entries are observed in the details log files in addition to errors such as:

1    Info    2015/04/09 18:34    Start [ Linux 3.2.0-4-amd64 (fserver), CyberSecure Advanced 6.23.0.0 ]
2    Info    2015/04/09 18:34    Start [ Linux 3.2.0-4-amd64 (fserver), CyberSecure Advanced 6.23.0.0 ]
3    Info    2015/04/09 18:34    Using Temporary Directory /tmp
4    Info    2015/04/09 18:34    Using Temporary Directory /tmp

and the following errors later in the backup:

Another backup job is still running. Backup skipped.
Unable to do Offsite backup, Error=
[Bptree.KeyRangeIterator.hasNext] Error=[BufferedRandomAccessFile][EOFException] /tmp/BackupSet/1394080712673…

Cause

This issue is caused by a corrupted local backup profile.

Resolution

Perform a local profile reset

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How to set a fixed profile location

  1. Find an existing valid local profile (.obm) folder
  2. Stop the online backup scheduler service
  3. Copy this folder into c:\cybersecure so it looks like c:\cybersecure\.obm
  4. Replace home.txt to contain only the following single entry: c:\cybersecure\.obm
  5. Set home.txt to read-only
  6. Restart the online backup scheduler service
  7. Check the scheduler log to confirm the next scheduled backup date(s)
  8. Open the backup agent to confirm it can see the new profile location
Posted in File backup: Server: issues with backup | Tagged , , , | Leave a comment